summarized values in drop-down

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

summarized values in drop-down

kkarra@stanford.edu
After a recent change to the featureType name changes, I see that in QueryBuilder and in database it has the new names. But, in certain templates it is showing old values while showing new values in one  of them.

I did run the relevant post-processes. Any idea why the drop-down values could still be the old ones?
    
<post-process name="create-attribute-indexes"/>
<post-process name="summarise-objectstore”/>

Thanks,
-Kalpana


_______________________________________________
dev mailing list
[hidden email]
http://mail.intermine.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: summarized values in drop-down

Julie Sullivan
Hi Kalpana

You had to redeploy your webapp after you rebuilt, correct? I could see
how the old values might be held in memory but if you re-released the
webapp those values would have been discarded. So I don't see how the
webapp could get the old values at all if they aren't in the database.

Try to restart the webapp again? Maybe it failed to redeploy properly?
Is this happening on yeastmine-dev? Can I view the templates?

Julie

On 26/11/14 04:21, Kalpana Karra wrote:

> After a recent change to the featureType name changes, I see that in
> QueryBuilder and in database it has the new names. But, in certain
> templates it is showing old values while showing new values in one  of them.
>
> I did run the relevant post-processes. Any idea why the drop-down values
> could still be the old ones?
> <post-process name="create-attribute-indexes"/>
> <post-process name="summarise-objectstore”/>
>
> Thanks,
> -Kalpana
>
>
>
> _______________________________________________
> dev mailing list
> [hidden email]
> http://mail.intermine.org/cgi-bin/mailman/listinfo/dev
>

_______________________________________________
dev mailing list
[hidden email]
http://mail.intermine.org/cgi-bin/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: summarized values in drop-down

Julie Sullivan
I may be wrong but it looks like the second template has everything but
tRNA_gene, here are the valid values:

ORF 5819
tRNA_gene 299
transposable_element_gene 91
snoRNA_gene 77
not in systematic sequence of S288C 55
rRNA_gene 27
ncRNA_gene 18
pseudogene 12
"" 12
snRNA_gene 6
telomerase_RNA_gene 1

I don't know why that one is missing! Weird. In mymine, next to that
template, is the summarised link enabled? e.g. does the webapp think that
template is summarised? Is it possible the template was edited?

Make a ticket and I'll investigate more.

> Hi Julie,
>
> I re-redeploed and checked,but, same issue.
>
> Yes, it is in yeastmine-dev - check these 2 templates..
>
> Thanks,
> -Kalpana
>
> http://yeastmine-test.yeastgenome.org/yeastmine-dev/template.do?name=gene_overlapping_flanking_regions&scope=global
> <http://yeastmine-test.yeastgenome.org/yeastmine-dev/template.do?name=gene_overlapping_flanking_regions&scope=global>
>
> vs
>
> http://yeastmine-test.yeastgenome.org/yeastmine-dev/template.do?name=FeatureType_Gene&scope=global
> <http://yeastmine-test.yeastgenome.org/yeastmine-dev/template.do?name=FeatureType_Gene&scope=global>
>
>
>
>> On Nov 26, 2014, at 2:18 AM, Julie Sullivan <[hidden email]> wrote:
>>
>> Hi Kalpana
>>
>> You had to redeploy your webapp after you rebuilt, correct? I could see
>> how the old values might be held in memory but if you re-released the
>> webapp those values would have been discarded. So I don't see how the
>> webapp could get the old values at all if they aren't in the database.
>>
>> Try to restart the webapp again? Maybe it failed to redeploy properly?
>> Is this happening on yeastmine-dev? Can I view the templates?
>>
>> Julie
>>
>> On 26/11/14 04:21, Kalpana Karra wrote:
>>> After a recent change to the featureType name changes, I see that in
>>> QueryBuilder and in database it has the new names. But, in certain
>>> templates it is showing old values while showing new values in one  of
>>> them.
>>>
>>> I did run the relevant post-processes. Any idea why the drop-down
>>> values
>>> could still be the old ones?
>>> <post-process name="create-attribute-indexes"/>
>>> <post-process name="summarise-objectstore”/>
>>>
>>> Thanks,
>>> -Kalpana
>>>
>>>
>>>
>>> _______________________________________________
>>> dev mailing list
>>> [hidden email]
>>> http://mail.intermine.org/cgi-bin/mailman/listinfo/dev
>>>
>
>


_______________________________________________
dev mailing list
[hidden email]
http://mail.intermine.org/cgi-bin/mailman/listinfo/dev