tblastx of alt-ESTs failing on single scaffold

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

tblastx of alt-ESTs failing on single scaffold

Daren C. Card
Hello,

I am having an issue running MAKER and am hoping to get some troubleshooting guidance. I am running MAKER v. 2.31.10 on a Unix cluster using a Singularity image with BLAST v. 2.9.0+ and Exonerate v. 3.3.2. I am running MAKER with the following command options: "-fix_nucleotides -nodatastore -RM_off". I am providing assembled transcripts from the target species (est) and a close relative (alt-est) and proteins from several species within the same general clade (Squamata). Gene models are being derived from Augustus with est2genome and protein2genome turned off. I have largely successfully run MAKER on a couple of genomes from the same vertebrate genus, but have this lingering problem with a single scaffold from one of the genomes. If it were pretty short, I'd just ignore it, but it is 2 Mb, so I do not want to miss out on annotating it.

When I ran MAKER on the entire genome, it finished properly except for this problematic scaffold. So I separated that scaffold out and tried running it alone with otherwise the same settings. Each time, it appears I get the same error during the 1st try when MAKER runs.
ERROR: TBLASTX does not appear to be finished in Widget::tblastx::keepers
--> rank=23, hostname=holy7c18405.rc.fas.harvard.edu
--> rank=23, hostname=holy7c18405.rc.fas.harvard.edu
--> rank=23, hostname=holy7c18405.rc.fas.harvard.edu
--> rank=23, hostname=holy7c18405.rc.fas.harvard.edu
ERROR: Failed while doing tblastx of alt-ESTs
ERROR: Chunk failed at level:4, tier_type:3
FAILED CONTIG:scaffold_77

ERROR: Chunk failed at level:4, tier_type:0
FAILED CONTIG:scaffold_77
Then MAKER keeps retrying and apparently hitting the same problem. I checked the logs the best I can and see the following issue within run.log.child.0 for that scaffold.
STARTED lerBou1_maker_rnd2.maker.output/lerBou1_maker_rnd2_datastore/scaffold_77/theVoid.scaffold_77/0/scaffold_77.0.lerEdw1_Trinity_combined_denovo_refguided%2Ecdhit%2Efasta.tblastx
DIED    RANK    17:4:0:0
DIED    COUNT   7
This output file noted there is not present to check, which must stem from whatever issue there is.

I'm not sure what to do next about this issue and see no obvious information about what the problem is besides failure of tblastx to run. Any help that anyone can provide is greatly appreciated.

Kind regards,
Daren Card

NSF Postdoctoral Fellow
Harvard University


_______________________________________________
maker-devel mailing list
[hidden email]
http://yandell-lab.org/mailman/listinfo/maker-devel_yandell-lab.org